Sendgrid Email outage
Incident Report for Realvolve CRM
Resolved
This incident has been resolved.
Posted Sep 26, 2016 - 17:25 UTC
Identified
Sendgrid is reporting Major outage for their Email service. Here is their status page http://status.sendgrid.com/
Posted Sep 26, 2016 - 14:36 UTC