Partial Outage
Incident Report for Realvolve CRM
Resolved
This incident has been resolved.
Posted Oct 18, 2016 - 15:48 UTC
Investigating
We are currently investigating this issue. One of the email blast from app is causing some slowdown.
Posted Oct 18, 2016 - 14:55 UTC